The Official DSI/Sequential Forum

Help : Tempest as sound module controlled by Ableton sequencer , Settings .

Hello, please help.  I need to sequence the Tempest with Ableton Live and so use the Tempest as a sound module.
It seems like the Tempest is not receiving any midi-notes messages from Ableton.

I have the following settings in the Tempest :

SYSTEM/ MIDI Remote pad Play

1. Remote Pad IN channel : ALL
2. Remote Pad OUT Channel : OFF
3. Pad note mode : sounds
4. MIDI Note : C0/ 0
etc..

SYSTEM / Polyphonic Keyboard play
1. MIDI Synth IN Channel : 1
2. MIDI Synth sound : A1
3. MIDI Synth root note : c5(60)
etc. ( as default settings).

In Ableton , in a MIDI channel , I created an External Instrument , settings are like shown in the pic.
And my Ableton MIDI settings are shown in a second pic.

Please help, it's been a long while I can't do this.

Sabina.




RobH

  • ***
  • 433
Set the "Remote Pad In" to a specific channel, the same one you have assigned on your "External Instrument" I use Ch.10 as this was originally the channel used for Midi Drums.

Your problem is that your using Midi Channel 1 for your Polyphonic sequencer channel and your external instrument is also sending midi to this channel, so depending on what you have programmed into Pad A1 you may not hear anything (if its a blank pad possibly?

Other than that your settings look ok.

Remember there are two different midi settings going on here. One is to trigger each individual pad and play it like a one shot; this is the Remote Pad IN

The other is to play notes of a synth patch programmed to one specific pad which is; Midi Synth Sound.

Seperate these two in your mind and approach one at a time.

Remote Pad will play all the pads (or beats assigned if you set it as such but i can see it set to "Sounds" so that should be fine).

Midi Synth will play a pad and change the pitch of whatever is programmed on that pad Drum or synth.

Sort your Remote PAD out first then decide on which pad and channel you'd like to use for Midi Synth Om


Thanks RobH. I followed  what you advice.
I appreciate it.

It does not work yet. 
I wonder what am I doing wrong.. possibly something in Ableton? Or any other MIDI setting in Tempest ? I am connecting Tempest
via USB , possibly that? (but I set all to IN OUT via USB).

I'd appreciate any help, thank you.



My settings are :

SYSTEM /MIDI remote PAD play

1. Remote Pad IN channel : 10
2. Remote Pad OUT Channel : Off
3. Pad Note mode : Off
4. MIDI not Pad a1 : C0/0 ... etc
---------------------------------
1. MIDI Synth IN Channel : Off
2. MIDI Synth sound : A1
3. MIDI SYnth Root note C5. etc...

System / MIDI CLOCK
1. Midi Clock Mode : Slave
2. Midi Clock IN cable : USB
3. Midi Clock OUT cable : NONE

System / MIDI SySex IN-OUT Cable : USB

IN ABLETON :

In a MIDI channel I created an "External instrument"
In the external Instrument I set :
MIDI TO : Tempest
Ch. 10.

In Ableton Preferences :

Control surface : None / Input : Tempest / Output : Tempest
Output Tempest : Enabled : Track Syn, Remote.



RobH

  • ***
  • 433
Hi. Ok so a weird thing happened. I tried out my Tempest with abelton just to make sure and it wasn't working either at first, so i checked my settings and reset my parameters etc and still it wouldn't work, i tried turning it on and off and every time i did this i got a messaged saying the USB device was un-recognised.

So I changed my USB ports and it reinstalled it properly. However i recently re-arranged all my kit and had changed my usb ports around and this was the first time i ran ableton since so it probably neeeded to go through that routine so i'm not 100% sure this is why your not getting it to work so all i can suggest are these things.

a) Change the USB port and see if it reinstalls the device and it just works.

b) Make sure that your Tempest is actually plugged into inputs 11/12

c) Make surethat you have ARMED the recording on that channel with the EXT instrument on it or you won't hear anything.

I double checked that everything worked as it should and it did other than my PC needing to reinstall the usb code because of my studio rejig. Also you could reset system parameters and go through the menus step by step again making sure everything is set correctly.

I'm sorry i cant be more help here, I think you understand the settings correctly as they look right, as i said make sure your track is armed and sending midi to the correct channel.