The Official DSI/Sequential Forum

Prophet 600 people?

Prophet 600 people?
« on: January 29, 2018, 04:22:03 PM »
Anyone here know the p600 a bit? My membrane screen is acting up and i think i may just need to reseat some ribbon cables to solve this but I dont know... The buttons function fine, but it only turns on half the time and when it does it looks like this..... Anyone know these old timers?


Re: Prophet 600 people?
« Reply #1 on: January 30, 2018, 01:18:13 AM »
Anyone here know the p600 a bit? My membrane screen is acting up and i think i may just need to reseat some ribbon cables to solve this but I dont know... The buttons function fine, but it only turns on half the time and when it does it looks like this..... Anyone know these old timers?



The LEDs are not part of the button assembly; if the unit turns on and functions half the time, you may have an issue with the microprocessor or ROM.

I'd consider a Gligli upgrade: https://gligli.github.io/p600fw/. It uses a slightly modified Teensy++ board (http://www.pjrc.com/store/teensypp_pins.html) that plugs into the Z80 socket.
Sequential / DSI / Pioneer stuff: Prophet-12 desktop, Pro-2, AS-1, Prophet-600 Gligli, Prophet 2000

Re: Prophet 600 people?
« Reply #2 on: February 06, 2018, 09:30:30 AM »
I'm on my second Teensy chip to try the GliGli mod...I'm going to try to install it this week, the first one didn't take and I can't tell if it's my synth of if the Teensy was flawed.... I had a tech replace all bunch of components and paid and arm and leg for it. But in the end he never got it to work with the GliGli Teensy mod, he put the z80 microprocessor back into the synth and it was working fine.... I was happy to have a functioning synth but it is not the outcome I wanted.... and then it starts acting up like in the pictures some months later. Wine Country guy said it looks CPU related as well based on those LEDs being all lit up and the screen not responding but the buttons still functioning as they should...