The Official DSI/Sequential Forum

'MIDI Thru Active' in Cubase makes P08 go mad...

'MIDI Thru Active' in Cubase makes P08 go mad...
« on: January 04, 2018, 02:05:10 PM »
As soon as I activate 'MIDI Thru' within Cubase (9.5) the P08 starts behave very strange (randomly) when turning knobs.

Some example:
- filter cutoff never never goes up to highest or lowest value
- changing programs works most of the times, but preset name never changes (stuck on the first one)
- none of the knobs will "easily" go from 0-127 and sometimes they just stop responding to the knob movements
- notes are not hung so the sound itself sounds OK

It's like the round-trip (MIDI loop) through my DAW flooding my P08 MIDI In, or something like that.
Everything works OK when turning MIDI Thru off and P08 in Local On.
But that's not how I would like to work, since I have other stuff connected to my DAW - USB-keyboard, modules and so on).

Anyway, to find out where the problem is I've disconnect everything but P08 which is connected to my DAW via USB Midi interface. Se the attached image...

Problem still remains.
Any suggestions?

Re: 'MIDI Thru Active' in Cubase makes P08 go mad...
« Reply #1 on: January 05, 2018, 02:53:19 AM »
Moinmoin,

in order to avoid MIDI loop, You must break the connection:
... P'08 MIDO out -> Cubase MIDI in -> Cubase MIDI out -> P'08 MIDI in -> P'08 MIDI out  -> Cubase MIDI in...
either at the Cubase or at the P'08 side.

Everything seems to be OK if You break the loop at the Cubase-side, as You wrote:
Quote
Everything works OK when turning MIDI Thru off and P08 in Local On.
Nothing coming in from P'08 to Cubase will be sent back to P'08.

To break the loop at P'08, set local control (in P'08 global settings) to Off. Nothing coming in from Cubase to P'08 will be sent back to Cubase. Don't forget to set P'08 global settings regarding MIDI parameter send / receive and MIDI program to Your purpose.
Every keypress, knob tweak, etc. will be sent from P'08 to Cubase and echoed back to P'08 sound modules, which will behave like they were internally connected as long as Cubase is present. If this is Your standard MIDI setup, everything is fine.

Personally however I prefer breaking the loop at the sequencer's side because I use my P'08 sometimes with, sometimes without sequencer. If I would break the loop at P'08 I would have to change its global settings every time I switch from or to sequencer use (which I might forget...).

There may be a 3rd method to break the loop within the USB to classical MIDI converter, breaking the loop here virtually pulls one MIDI cable at the P'08 (which obviously is the 4th method), so I would leave that untouched.

HTH

Martin

Re: 'MIDI Thru Active' in Cubase makes P08 go mad...
« Reply #2 on: January 05, 2018, 02:08:39 PM »
Thx. I think I have narrow it down to the USB MIDI interface I'm using (M-Audio Midisport).
Turns out it doesn't run very well on Windows 8.1/10 (shitty drivers).

On regular basis I have to disconnected the USB cable from the Midisport and then everything works like I should again.

Note to self; buy new MIDI interface...