The Official DSI/Sequential Forum

Envelope Triggering Question

Envelope Triggering Question
« on: November 02, 2017, 12:52:41 PM »
I've created a patch that uses Layer A and Layer B Stacked.

When I hit one note it uses Two Voices and Two LEDs light up on the front panel to indicate two voices are in use, so far it makes sense.

What doesn't make any sense to me is the Envelope Triggering that occurs:

If I keep one note held down and play a second note then both notes will sound and all four Voices are used, so far so good.

But if I let go of one note and hit the next note before the first note has finished it's Release Phase it then re-uses the same two voices resulting in an annoying percussive sound which I can only conclude is the Release phase being cut off abruptly so that the Attack Phase can be re-triggered for the next note?

If the Tetra would just use the other two voices that are available then that wouldn't happen?

It also does the same thing in Unison Mode but then that is understandable because all four voices are used and it has no choice but to re-trigger the Envelope.

Am I missing something?


Re: Envelope Triggering Question
« Reply #1 on: November 03, 2017, 07:36:49 AM »
I should have mentioned I am running:

OS Version 1.5
Voice Version 1.2

The official ones.

chysn

  • *****
  • 857
Re: Envelope Triggering Question
« Reply #2 on: November 03, 2017, 09:17:43 AM »
This may or may not be helpful, because I never owned a Tetra. But on my Mophos, there was a Key Assign parameter that determined whether the synth re-triggered envelopes. Of course, they were monophonic, so it might not be relevant here, but have you tried different Key Assign values?
DSI: DSM03; previously: Mopho Keyboard, Desktop Mopho, Evolver, DSM01
Hardware: Eurorack, Moog Little Phatty w/ CV Outs, Arturia MicroBrute, KMI QuNexus
Software: macOS, Ableton, MuseScore
Modular Grid: https://www.modulargrid.net/e/racks/view/354385
GitHub: https://github.com/chysn

Re: Envelope Triggering Question
« Reply #3 on: November 03, 2017, 10:55:47 AM »
I just tried all the Key Assign Modes, same thing happens.

I just tried turning off the A/B Stacking, same thing happens.

I just tried the latest BETA Firmware, OS 1.6.19 and Voice 1.5.12, same thing happens.

It's as if it doesn't matter how many voices are available if the note is in it's RELEASE Phase it will always cut it off and re-use the same Voice like it still thinks it's a MONO Synth???

panic

Re: Envelope Triggering Question
« Reply #4 on: November 09, 2017, 02:32:19 AM »
Perhaps I do not understand you right, but what you are describing indeed does not sound right to me. Normally, tetra cycles through the available voices. To make sure, try this and see if it works as described:
- use the normal polyphonic mode (make sure you're not in any unison mode), take a patch with long release
- press 1 key: the led of voice 1 should light up
- release key: led of voice 1 goes out, but release is still sounding
- while still in release phase, press a new key: voice 2 led lights up and voice 2 sounds, while release of voice one is still sounding

This is the normal behavior (for example, look at the video where dave smith demonstrates the mopho-tetra polychain: after giving the explanation, he plays a number of subsequent notes, and you see tetra cycling through the voices).

Key assign modes only have functionality in unison mode, they should indeed not impact anything in polymode.