The Official DSI/Sequential Forum

My Pro-2 seems to have perished. :(

My Pro-2 seems to have perished. :(
« on: September 16, 2017, 01:13:54 PM »
Hi All,

I fired up my Pro-2 today after a few weeks of not using it much, and to my surprise it's not outputting any sound. So far I have:

- Twiddled every knob, and pressed every button
- Made sure Local Control is ON
- Made sure Show is OFF
- Reseated all the internal cables
- Powered it off for a while and powered it back on
- Tried both L/R outputs and headphones with multiple cables
- Removed USB/MIDI, and also tried sending MIDI notes
- Verified MIDI is being sent from the Pro-2 as normal
- Verified MIDI is being received by the Pro-2 as normal (set sequencer to Key mode, sent notes)
- Updated OS to 1.3
- Reset globals
- Emailed DSI support

I'm pretty sure this is gonna be a support issue, and will probably involve swapping boards or sending it in. But in the meantime since i hadn't found any other such posts about mysteriously silent Pro-2s I thought I'd start one.

Any suggestions?

Re: My Pro-2 seems to have perished. :(
« Reply #1 on: September 16, 2017, 04:53:40 PM »
Hi All,

I fired up my Pro-2 today after a few weeks of not using it much, and to my surprise it's not outputting any sound. So far I have:

- Twiddled every knob, and pressed every button
- Made sure Local Control is ON
- Made sure Show is OFF
- Reseated all the internal cables
- Powered it off for a while and powered it back on
- Tried both L/R outputs and headphones with multiple cables
- Removed USB/MIDI, and also tried sending MIDI notes
- Verified MIDI is being sent from the Pro-2 as normal
- Verified MIDI is being received by the Pro-2 as normal (set sequencer to Key mode, sent notes)
- Updated OS to 1.3
- Reset globals
- Emailed DSI support

I'm pretty sure this is gonna be a support issue, and will probably involve swapping boards or sending it in. But in the meantime since i hadn't found any other such posts about mysteriously silent Pro-2s I thought I'd start one.

Any suggestions?

It won't solve your problem, but have you tried using the external input?
Sequential / DSI / Pioneer stuff: Prophet-12 desktop, Pro-2, AS-1, Prophet-600 Gligli, Prophet 2000

Re: My Pro-2 seems to have perished. :(
« Reply #2 on: September 16, 2017, 06:03:16 PM »
It won't solve your problem, but have you tried using the external input?

Oops, I forgot to add that to my list of things I tried. No external input, no self-oscillating filters, nada. Just dead silence.