The Official DSI/Sequential Forum

Voices randomly falling out

idm

Voices randomly falling out
« on: April 19, 2017, 07:41:59 AM »
Hi,

Sigh... I love the Tempest. I really do. Been making really great crunchy dark techno with it. But this problem is kind of killing my vibe...

When creating a beat, sometimes a voice, sometimes even multiple voices will suddenly drop out. And they won't work until I reboot the Tempest.

Another strange thing which might be related is that some sounds just drop off the earth for 1 loop and then come back.

I run the latest beta, calibrated multiple times etc. Etc.

Anybody else having this issue?

Re: Voices randomly falling out
« Reply #1 on: April 19, 2017, 07:49:36 AM »
Hi,

Sigh... I love the Tempest. I really do. Been making really great crunchy dark techno with it. But this problem is kind of killing my vibe...

When creating a beat, sometimes a voice, sometimes even multiple voices will suddenly drop out. And they won't work until I reboot the Tempest.

Another strange thing which might be related is that some sounds just drop off the earth for 1 loop and then come back.

I run the latest beta, calibrated multiple times etc. Etc.

Anybody else having this issue?

I was having this issue.  What I discovered was that sounds I made in 1.4.5.1 were causing the issue in 1.4.5.2, so I recreated the sounds and resaved them and the problem went away.  I also just got my Tempest like a month ago, so I only had a dozen patches to recreate so it was a relatively simple fix for me... but that could be a bigger problem if you have more content obviously.

When I was emailing tech support about it they recommended just playing with the factory projects to see if the issue occurs there.  Might be worth trying.

idm

Re: Voices randomly falling out
« Reply #2 on: April 19, 2017, 07:52:36 AM »
Thanks for the reply. I'm actually having this issue with newly created sounds as well.

Re: Voices randomly falling out
« Reply #3 on: April 19, 2017, 07:59:39 AM »
Thanks for the reply. I'm actually having this issue with newly created sounds as well.

What I actually did was erase everything on the Tempest and reloaded the factory content along with the handful of 1.4.5.2 created patches I had made and backed up.  Might've been overkill, but it worked.

idm

Re: Voices randomly falling out
« Reply #4 on: April 19, 2017, 08:05:36 AM »
Ah :). Worth a try, thanks!

RobH

  • ***
  • 354
Re: Voices randomly falling out
« Reply #5 on: April 19, 2017, 09:14:24 AM »
I've been having this problem as well, a lot of voices dropping out, assigning voices usually sorted the problem to me but the voice allocation is defo having some issues for me at least.

Someone should mention it in the bug forum.

Re: Voices randomly falling out
« Reply #6 on: May 01, 2017, 11:13:40 AM »
Also having this issue. Mostly happens when a polysynth part is playing on loop, eventually one or two of the oscillators will drop out or the kick will disappear. Curious what is happening.

dsetto

  • **
  • 232
Re: Voices randomly falling out
« Reply #7 on: May 04, 2017, 06:15:56 AM »
Could you explain to me how I can recreate the environment to assess what you're experiencing?

Re: Voices randomly falling out
« Reply #8 on: May 04, 2017, 08:39:04 AM »
Could you explain to me how I can recreate the environment to assess what you're experiencing?

This just started happening to me again as well after updating to 1.4.5.6.  I posted the details of what was happening to me in the Bug Reports thread, and I'll just copy it here for future visibility to anyone looking at this thread:

Just updated to 1.4.5.6 and immediately I'm having the issue where one of my voices has dropped out and stopped working.  When this previously happened to me, I suspected it was custom sounds I had created in an earlier beta causing the problem, so I wiped all my custom projects and sounds and rebuilt them and it fixed my problem. The longer I use the Tempest obviously the more tedious that process becomes though... so some kind of fix from DSI would be preferable.

I calibrated the oscillators and reset the system parameters, all the usual stuff after updating.  After a few minutes of playing one of my voices stops working, which I verify by assigning a single sound to the different voices and playing it by itself (no sequencer running) and discovering that a voice is now completely silent (in the case that just occurred, it was Voice 3).  The problem goes away after I restart the unit, but then comes back eventually.

dsetto

  • **
  • 232
Re: Voices randomly falling out
« Reply #9 on: May 04, 2017, 04:54:27 PM »
AdamXAudio, is your voice loss problem happening with files (Projects, Beats, Sounds) created in current Beta?

Can either of you instruct me how to assess this issue on my end?

(I am not on latest OS yet; but I want to try it when I get a chance.)

Re: Voices randomly falling out
« Reply #10 on: May 04, 2017, 05:11:41 PM »
AdamXAudio, is your voice loss problem happening with files (Projects, Beats, Sounds) created in current Beta?

Can either of you instruct me how to assess this issue on my end?

(I am not on latest OS yet; but I want to try it when I get a chance.)

So, my process is I initialize the project, and then start loading in Sounds I created in the last two Betas. I then sequence with the sounds as I normally would, and I eventually notice voices dropping out abruptly, even though I'm coming nowhere close to the 6-voice limit.  It doesn't always happen at the same time... but usually within 15-20 minutes of use it'll occur, if not much sooner.

cbmd

  • *****
  • 160
    • Dave Smith Instruments
Re: Voices randomly falling out
« Reply #11 on: May 04, 2017, 05:53:28 PM »
Does this occur if you use sounds not created on the latest BETA OS versions?
Dave Smith Instruments

Re: Voices randomly falling out
« Reply #12 on: May 04, 2017, 06:36:34 PM »
Does this occur if you use sounds not created on the latest BETA OS versions?

Since it occurs kind of randomly, I'll need to check it more.  The last time this happened to me, I did a test where I only used the factory projects/sounds for an extended period of time, and the issue would not occur.  It only happened when I used my sounds saved in the beta. If it's helpful at all Carson, my technical support exchange from when this last happened to me was Request #35178.

dsetto

  • **
  • 232
Re: Voices randomly falling out
« Reply #13 on: May 04, 2017, 09:58:59 PM »
AdamXAudio, is your voice loss problem happening with files (Projects, Beats, Sounds) created in current Beta?
...

So, my process is I initialize the project, and then start loading in Sounds I created in the last two Betas. ...


Got it. ... DSI Support has suggested to me that I limit assessment of my Beta issues to either Factory-provided files or files created in the current Beta. I'm very interested in reading your results under those conditions.



Re: Voices randomly falling out
« Reply #14 on: May 05, 2017, 05:32:13 AM »
AdamXAudio, is your voice loss problem happening with files (Projects, Beats, Sounds) created in current Beta?
...

So, my process is I initialize the project, and then start loading in Sounds I created in the last two Betas. ...


Got it. ... DSI Support has suggested to me that I limit assessment of my Beta issues to either Factory-provided files or files created in the current Beta. I'm very interested in reading your results under those conditions.

Understandable, but is the implication that I shouldn't expect my old files created in earlier Betas to work after an update?  If that's the case I might just hold off on saving new files on the Tempest until a final OS is actually released, as it's a bit of a pain to recreate them every time a new Beta comes out.  When I get the time I'll test things using the Factory content only, thanks.

dsetto

  • **
  • 232
Re: Voices randomly falling out
« Reply #15 on: May 05, 2017, 09:41:34 AM »

...
Understandable, but is the implication that I shouldn't expect my old files created in earlier Betas to work after an update?
This is my interpretation. It may have even been communicated to me.

I see it as the "small, fine print."
It makes total sense to me, for methodological motivations. I see it as the responsibility that comes with the privilege to Beta test an instrument I care about.

But, for those that this is a problem, they can find ways around it. (And I can appreciate why.) My suggestions are:
1. Don't get involved in Beta assessing.*
2. Change workflow/mindset that can accommodate this potential file incompatibility scenario with the last official OS.
3. Stay in whatever OS you feel may have greatest chance of being compatible with last OS. And, if you have a free session or  four, test your most vital functions in current OS, and then go back to your "file compatibility" OS.

 *Not assessing this current Beta OS is a little like voting for a bill without reading it. I.e., if you can find time to assess it, or accommodate the temporary state of potential future file incompatibility that seems to accompany assessing Betas, do it.



 If that's the case I might just hold off on saving new files on the Tempest until a final OS is actually released, as it's a bit of a pain to recreate them every time a new Beta comes out. 
Sounds reasonable.


When I get the time I'll test things using the Factory content only, thanks.
!!!!

I think all Beta folk should adopt this, if and when they encounter an issue.  (I believe it will reduce frustration on forum.)

Re: Voices randomly falling out
« Reply #16 on: May 05, 2017, 10:22:05 AM »

...
Understandable, but is the implication that I shouldn't expect my old files created in earlier Betas to work after an update?
This is my interpretation. It may have even been communicated to me.

I see it as the "small, fine print."
It makes total sense to me, for methodological motivations. I see it as the responsibility that comes with the privilege to Beta test an instrument I care about.

But, for those that this is a problem, they can find ways around it. (And I can appreciate why.) My suggestions are:
1. Don't get involved in Beta assessing.*
2. Change workflow/mindset that can accommodate this potential file incompatibility scenario with the last official OS.
3. Stay in whatever OS you feel may have greatest chance of being compatible with last OS. And, if you have a free session or  four, test your most vital functions in current OS, and then go back to your "file compatibility" OS.

 *Not assessing this current Beta OS is a little like voting for a bill without reading it. I.e., if you can find time to assess it, or accommodate the temporary state of potential future file incompatibility that seems to accompany assessing Betas, do it.



 If that's the case I might just hold off on saving new files on the Tempest until a final OS is actually released, as it's a bit of a pain to recreate them every time a new Beta comes out. 
Sounds reasonable.


When I get the time I'll test things using the Factory content only, thanks.
!!!!

I think all Beta folk should adopt this, if and when they encounter an issue.  (I believe it will reduce frustration on forum.)

Thanks for the insight Dsetto! I don't think it's written anywhere in the Beta download section, but it might be nice if it could be stated that Beta saved content may cause issues when loaded into future Beta updates.  If the intention is that everyone using the Betas "start fresh" from factory settings after each update to properly debug it, that'd be good to know outright to help with debugging and avoid some user confusion/frustration.

As a side note, I've been messing around only with factory content this morning and haven't had my voices drop out, so it probably points to problems using my earlier saved Beta sounds.


dsetto

  • **
  • 232
Re: Voices randomly falling out
« Reply #17 on: May 05, 2017, 10:41:22 AM »
... I don't think it's written anywhere in the Beta download section, but it might be nice if it could be stated that Beta saved content may cause issues when loaded into future Beta updates. 
I also don't know if it's written anywhere. I have the vague notion I read a bunch of reasonable disclaimers on one of these Beta threads, relating to using the Tempest Beta. I agree it would be useful (if it hasn't already been written in the beginning of a sticky Beta thread.)

If the intention is that everyone using the Betas "start fresh" from factory settings after each update to properly debug it, that'd be good to know outright to help with debugging and avoid some user confusion/frustration.
I learned to do this after encountering my first issues. ... I think one way to approach it is to use "start fresh", upon encountering an issue. It's a nuance, but it makes the greatest win-win overall, between users & DSI.

As a side note, I've been messing around only with factory content this morning and haven't had my voices drop out, so it probably points to problems using my earlier saved Beta sounds.
That is absolutely awesome! ... As I haven't had a chance to install the current beta, I am very interested in your assessments. (I'm 2 betas short, but I've tested the most important things to me already.)

Re: Voices randomly falling out
« Reply #18 on: May 05, 2017, 01:33:57 PM »
Unfortunately after some more testing this problem DID happen to me using only Factory sounds (specifically the Burnt Neon & Funk Kit project).

Basically, I just erased a beat and created my own pattern.  I made a fairly busy sequence, one that would surely use all 6 voices at once in certain parts of the beat, but not steal voices.  I let the beat just run on loop in the background, and eventually after a few minutes it started acting strange and dropping voices.  When I stopped the sequence, I then tried assigning a sound to a specific voice and sure enough Voice 1 had gone completely silent on me.


Re: Voices randomly falling out
« Reply #19 on: May 22, 2017, 02:31:14 AM »
I've been struggling with this issue as well. For example, I had a fairly simple drum beat (3-4 voices assigned) playing and suddenly V3 (hihat) drops out. I tried to swith between projects but the V3 is not working without restarting the whole unit. And this happens quite often. I'm using the latest OS and voice.

Any further information about this bug yet?

Thanks.
« Last Edit: May 22, 2017, 02:33:15 AM by AnssiTir »